Função soma() & potencia()

algoritmo "função"
// Função :
// Autor :
// Data : 01/11/2018
// Seção de Declarações 
 // reservada   nome ( lista de variáveis : tipo): tipo de retorno
funcao soma(x, y :inteiro):inteiro
inicio
   retorne x+y

fimfuncao

funcao potencia(x, y:inteiro):inteiro
var  pot, i:inteiro
inicio
   pot:=1;
   para i de 1 ate y passo 1 faca
       pot:= pot*x
   fimpara
   retorne pot
fimfuncao
var
   op:caracter
   v1,v2: inteiro
 inicio
 
    // escreval(soma(2,3))
     escreval(potencia(2,5))
 
 
 
 
// Seção de Comandos 
  escreval( "Calculadora")
  escreva("Digite a Operação [*] [/] [+] [-] [^] [#]")
  leia(op)
  se op='#' entao
     escreva("Digite o Valor:")
     leia(valor)
     escreva(quadrado(valor))

  
        // escreva( " "soma(2,4)  )

fimalgoritmo

Ordenação de Vetor

algoritmo "semnome"
// Função :
// Autor :
// Data : 10/10/2018
// Seção de Declarações 
var
         notas: vetor [1..10] de inteiro
         i,j,aux: inteiro
inicio
// Seção de Comandos 
        // INSERIR VALORES NO VETOR
        escreval("Digite as notas de  ")
        para  i de 1 ate 4 passo 1 faca
              escreva("Digite a nota do aluno ",i," : ")
              leia(notas[i])
        fimpara
        
        //ORDENAÇÃO
        para i de 1 ate 3 passo 1 faca
            para j de i+1 ate 4 passo 1 faca
                 se (notas[i] < notas[j]) entao
                    aux:= notas[i]
                    notas[i]:=notas[j]
                    notas[j]:=aux
                 fimse
            
            
            fimpara
        fimpara
        

          // APRESENTAR VALORES NO VETOR
        para  i de 1 ate 4 passo 1 faca
               escreval("Valor na posição: ",i," Valor:",notas[i])

        fimpara

fimalgoritmo

Quantos Pares

algoritmo "Quantos são Pares"
// Função :
// Autor :
// Data : 11/10/2018
// Seção de Declarações 
var
 num: vetor[1..10] de inteiro
 i,par:inteiro
 
inicio

// Seção de Comandos
  par:=0
   // BLOCO COM LAÇO PARA INSERIR VALORES
  para  i de 1 ate 5 passo 1 faca
        escreva("Digite um Número: ")
        leia(num[i])
  fimpara

  // BLOCO COM LAÇO PARA APRESENTAR VALORES
  para  i de 1 ate 5 passo 1 faca
        se (num[i]%2=0) entao
           par:=par+1
        fimse
  fimpara

  escreva("Você digitou ",par, " Números Pares")
  

fimalgoritmo