Ordenação de Vetor

Ordenação de Vetor

algoritmo "semnome"
// Função :
// Autor :
// Data : 10/10/2018
// Seção de Declarações 
var
         notas: vetor [1..10] de inteiro
         i,j,aux: inteiro
inicio
// Seção de Comandos 
        // INSERIR VALORES NO VETOR
        escreval("Digite as notas de  ")
        para  i de 1 ate 4 passo 1 faca
              escreva("Digite a nota do aluno ",i," : ")
              leia(notas[i])
        fimpara
        
        //ORDENAÇÃO
        para i de 1 ate 3 passo 1 faca
            para j de i+1 ate 4 passo 1 faca
                 se (notas[i] < notas[j]) entao
                    aux:= notas[i]
                    notas[i]:=notas[j]
                    notas[j]:=aux
                 fimse
            
            
            fimpara
        fimpara
        

          // APRESENTAR VALORES NO VETOR
        para  i de 1 ate 4 passo 1 faca
               escreval("Valor na posição: ",i," Valor:",notas[i])

        fimpara

fimalgoritmo
mario

Os comentários estão fechados.