Função soma() & potencia()

Função soma() & potencia()

algoritmo "função"
// Função :
// Autor :
// Data : 01/11/2018
// Seção de Declarações 
 // reservada   nome ( lista de variáveis : tipo): tipo de retorno
funcao soma(x, y :inteiro):inteiro
inicio
   retorne x+y

fimfuncao

funcao potencia(x, y:inteiro):inteiro
var  pot, i:inteiro
inicio
   pot:=1;
   para i de 1 ate y passo 1 faca
       pot:= pot*x
   fimpara
   retorne pot
fimfuncao
var
   op:caracter
   v1,v2: inteiro
 inicio
 
    // escreval(soma(2,3))
     escreval(potencia(2,5))
 
 
 
 
// Seção de Comandos 
  escreval( "Calculadora")
  escreva("Digite a Operação [*] [/] [+] [-] [^] [#]")
  leia(op)
  se op='#' entao
     escreva("Digite o Valor:")
     leia(valor)
     escreva(quadrado(valor))

  
        // escreva( " "soma(2,4)  )

fimalgoritmo
mario

Os comentários estão fechados.