Jogo da Velha

Jogo da Velha

algoritmo "JogoDaVelha"
// Função :
// Autor :
// Data : 22/10/2018
// Seção de Declarações 
var
 m : vetor [0..2,0..2] de caractere
 jogador: caractere
 i,j,l,c,x,y: inteiro
 
 funcao testaVencedor(p: caractere) : inteiro
 inicio
 
   se (m[0,0]= p) e ( m[0,1]= p) e  ( m[0,2]= p) entao
       retorne 9
   senao
        retorne 0
   fimse
 
 fimfuncao

procedimento mostrar()
inicio

  para i de 0 ate 2 passo 1 faca

        para j de 0 ate 2 passo 1 faca
              escreva(m[i,j])
        fimpara
        escreval()
    fimpara
fimprocedimento

procedimento jogar()
inicio
      escreval()
      escreval("Jogador: [ ",jogador, " ]")

      escreva("Digite a linha:")
      leia(l)
      escreva("Digite a coluna:")
      leia(c)

      enquanto m[l,c] <> " " faca
               escreval("Escolha outra posição:")
               escreva("Digite a linha:")
               leia(l)
               escreva("Digite a coluna:")
               leia(c)
      fimenquanto
      
      m[l,c]:= jogador
fimprocedimento

inicio

jogador:="X"
y:= 0 // não encontrou
// Seção de Comandos 

para i de 0 ate 2 passo 1 faca
   para j de 0 ate 2 passo 1 faca
     m[i,j]:= " "
   fimpara
fimpara

enquanto (y<5) FACA
  limpatela
  jogar()
  y := y + testaVencedor(jogador)
  mostrar()


  //mudar o jogador
  se jogador="X" entao
      jogador:="0"
  senao
       jogador:="X"
  fimse

y:=y+1
fimenquanto

fimalgoritmo
mario

Os comentários estão fechados.
Evento Arduino